Eclipse (Pleiades) or Maven で Java8 対応の CheckStyle を使う

Java8 のシンタックス (ラムダとか!) を使ってるコードに CheckStyle したら、 Eclipse (Pleiades) でも Maven でもエラーになった。 どっちも CheckStyle 本体のバージョンが古いのが原因だった。 Java8 対応のバージョンになるのも時間の問題だろうけど、 それぞれで使う CheckStyle をバージョンアップ出来たので、や…