How can I run Xcode 12.5.1 on Monterey?

I am facing a problem running older versions of Xcode on new Monterey OS.