jupyter-client has to be installed but “jupyter kernelspec --version” exited with code 127

I have already installed Jupyter notebook in my ubuntu 16.04 machine. In jupyter notebook there is by default python installed. Now I want to use R from jupyter notebook. To do so I followed IRke...